Upgraded to Picsender 3.4.2 - now with problems?

Topic's about PicSender
Forum rules
Be Kind to other's.
No Cussing or Swearing.
Don't post anything Illegal or Obscene.
Image attachment size limit is 500 KiB.
willow
Posts: 15
Joined: Mon Apr 16, 2018 4:28 am

Upgraded to Picsender 3.4.2 - now with problems?

Postby willow » Wed Oct 14, 2020 5:26 am

Have just upgraded to v3.4.2 of Picsender and it will now not let me clear the highlighted red 'Alarm Lock' state. Have also got 'GRBL Reset' highlighted in Red as well as 'chk Gcode Active'.

Have tried the re-setting of GRBL in an attempt to clear all these conditions , but nothing seems to make any difference.

Have now reverted to my previous setup and all is still working as normal - any ideas as to why this is happening?

Willow :cry:

User avatar
Picengraver
Full Access Moderator
Posts: 366
Joined: Tue Dec 23, 2014 5:40 pm
Contact:

Re: Upgraded to Picsender 3.4.2 - now with problems?

Postby Picengraver » Wed Oct 14, 2020 6:01 am

What is your "previous setup?" An earlier version of PicSender?
What you are describing sounds as though grbl is in a "locked" state waiting for the homing ($H) function to be initiated.
You should get a startup message in the Messages box that reads, "Reference Home ($H) is enabled"
PS Startup.jpg
PS Startup.jpg (75.94 KiB) Viewed 153 times


Did you try clicking the $H button?

John

User avatar
Picengraver
Full Access Moderator
Posts: 366
Joined: Tue Dec 23, 2014 5:40 pm
Contact:

Re: Upgraded to Picsender 3.4.2 - now with problems?

Postby Picengraver » Wed Oct 14, 2020 6:10 am

Sorry, have reread you message. Seems you have found a bug. Try again, but DO NOT click the "$C" button. Make sure it stays reading "Inactive" as above and you should be OK. I will get a fix out later today. My apology and thanks for letting me know.

willow
Posts: 15
Joined: Mon Apr 16, 2018 4:28 am

Re: Upgraded to Picsender 3.4.2 - now with problems?

Postby willow » Wed Oct 14, 2020 7:19 am

Will wait until later if a fix is imminent - have tried it all ways up until now and I'm not sure that I've not already tried your suggestion...
I can be patient as I have already moved back to v3.5.2 (my previous setting) which is still working fine.

Willow

User avatar
Picengraver
Full Access Moderator
Posts: 366
Joined: Tue Dec 23, 2014 5:40 pm
Contact:

Re: Upgraded to Picsender 3.4.2 - now with problems?

Postby Picengraver » Wed Oct 14, 2020 7:35 am

OK, I will try to get it out today. I have verified the bug and a potential fix, but need time to test well. Doing as I suggested will allow normal operations for now. No other users have reported this issue. Thank you for your report.

User avatar
Picengraver
Full Access Moderator
Posts: 366
Joined: Tue Dec 23, 2014 5:40 pm
Contact:

Re: Upgraded to Picsender 3.4.2 - now with problems?

Postby Picengraver » Wed Oct 14, 2020 7:11 pm

A fixed version of PicSender (v3.4.2b) will be posted later today.
John

User avatar
Picengraver
Full Access Moderator
Posts: 366
Joined: Tue Dec 23, 2014 5:40 pm
Contact:

Re: Upgraded to Picsender 3.4.2 - now with problems?

Postby Picengraver » Sun Oct 18, 2020 7:01 pm

PicSender version 3.5.0 released today. Some internal code changes, some bug fixes, and keyboard arrow keys and Page Up/Page Down keys now work for continuous jogging.


Return to “PicSender”

Who is online

Users browsing this forum: No registered users and 1 guest

cron